Registration is FREE and takes seconds to complete!
Club-tC Members Receive:
? Advertisement Free Browsing
? Access to all tC Tech Articles
? Ability to post questions and comments
? Use of private message system
? Ability to share images
? Their own personal profile page
? More tC information then anywhere else
Sign Up Now!

MAF Contamination From CAI/SRI

Discussion in 'Engine' started by navylife59, May 16, 2008.

Thread Status:
Not open for further replies.
  1. navylife59
    Offline

    navylife59 Super Moderator Staff Member

    Joined:
    Mar 22, 2006
    Location:
    Emory, Texas or Gretna, LA
    Apparently many Toyota Techs are not very adept at troubleshooting issues with a lean or rich running motor being quick to blame your CAI/SRI for contaminating/damaging your factory MAF sensor. From oil contamination, to water damage, to even metal flakes have been the quick diagnosis. Many times the MAF is replaced, instead of, cleaned costing the owner an expensive "out-of-warranty" repair. While there are a few sensors that are contaminated by cheap oiled type filters, the majority of Dealer's claims are unfounded. If it were the case, then why does Scion offer an optional TRD (AEM) CAI?

    The following information is directly from K&N and maybe biased towards ther product. As with all online information, it is for reference and not to be considered the absolute expert information. You will notice how many Toyota MAFs are diagnosed "good".

    K&N Contaminated MAF Investigation

    Note: This topic is closed to posts. If you have any information to further this topic, please PM and I will add it with reference to you.
     
Thread Status:
Not open for further replies.

Share This Page